3.3.1官方下载的源码有问题,亲测

3.3.1官方下载的源码有问题,老是安装不成功。

错误请见:https://wenda.tipask.com/question/8045

首先我用windows2008+iis7.0+php5.6.9+mysql5.5,测试了是这个错误。

然后我又使用了官方推荐的宝塔进行安装,安装方法是按照教程【https://wenda.tipask.com/article/5107】一步一步操作的。同样也是Nginx-1.12,php5.6,mysql5.5 安装时到最后一步,同样提示上面的错误。

建议管理员自己从官方下载安装包,测试一下安装, 是不是这个问题。

后面我从网下下载了tipask3.2,再一次测试安装。安装方法和上面是完全一样的,非常正常。 3.2可以安装成功。

所以我只想说,肯定是是官方给的安装包有问题。

请先 登录 后评论

4 个回答

sdf_sky - Tipask官方技术支持
擅长:tipask,php,服务器,网站建设

IIS7版本有点太低了。

你自己本地windows安装一下看看。3.3版本对一些核心composer包进行升级了.

给个qq私信一下,我们会联系你确认一下。

请先 登录 后评论
Hellsing

确实有问题。

新版本出来后,我第一时间覆盖升级,报错。

我测试了下,删除程序,数据库,根目录,全部删除。

重新安装了3.2,全新的3.2,然后用3.3.1去覆盖升级,还是打开有问题。

登录账号后,页面除了导航外,全部空白,并且有的页面会报错。

用3.2版本的 inflector.php 程序 覆盖 3.3.1的这个文件,就可以了,目前能找到的就是这个解决办法。

新旧文件大小不一样,覆盖后,能正常使用,但是不知道是否会有其他的隐藏问题出现。

建议现在不要用新版本,最好还是等待官方找出问题,修复下,等3.3.2的版本吧。

请先 登录 后评论
Lost

搞了几天了,3.3.1一直安装不成功,气死了!!!


Whoops, looks like something went wrong.

1/1FatalErrorException in /usr/share/nginx/tipask331/vendor/doctrine/inflector/lib/Doctrine/Common/Inflector/Inflector.php line 265:syntax error, unexpected ':', expecting ';' or '{'

请先 登录 后评论
vibeta

我安装到最后也遇到这样的问题,登录账号后,页面除了导航外,全部空白

Whoops, looks like something went wrong.
1/1FatalErrorException in /usr/share/nginx/tipask331/vendor/doctrine/inflector/lib/Doctrine/Common/Inflector/Inflector.php line 265:syntax error, unexpected ':', expecting ';' or '{'
  1. in Inflector.php line 265

怎么解决啊

请先 登录 后评论